Commandes CISCO

Très petit résumé des commandes Cisco.

Lancer une console en hyperterminal ( Windows ) en 9600 8N1, et se connecter avec un câble Cisco

cnx pc routeur

Paramétrage des ports Ethernet.

Router1>enable                                                                      passer en mode root.
Router1#configure terminal                                            ou conf term.
Router1(config)#interface f0/0                                       configurer le 1er port Ethernet.
Router1(config-if)#ip add 192.168.1.131 255.255.255.0 adresse IP et masque.
Router1(config-if)#no shutdown                                                                  
Router1(config-if)#exit
Router1(config)#interface f0/1                                         configurer le 2e port Ethernet.
Router1(config-if)#ip add 10.0.0.1 255.0.0.0                   adresse IP et masque.
Router1(config-if)#no shutdown
Router1(config-if)#exit                                                          retour sous-menu.
Router1(config)#exit                                                               retour sous-menu.
Router1#copy running config startup config            sauvegarder la configuration .
Router1#show running-config                                        affiche la config. du routeur.
Router1#show ip interface brief                                     affiche l’état des interfaces.

Construction d’une route.

Router1>enable
Router1#ip route   192.168.1.0    255.255.255.0    10.168.2.1
Router1#show ip route                              ( Réseau destination+masque via passerelle )

 Vérification d’une route.

Au niveau de la console sur routeur :

  • Show ip int brief
  • Show ip route
  • Ping sur les interfaces.
  • Traceroute.

Sous Windows ( en mode cmd )

  • Tracert –d + adresse IP de destination
  • Ping sur les interfaces
  • Route print

Il y a deux façons de construire une route :

  • Soit en précisant nommémant la route.
  • Soit en construisant une route « par défaut » .

On peut faire :

  • Router1# ip route 30.0.0.0 255.0.0.0 20.0.0.1 soit ip route destination + masque via passerelle.
  • Router1#ip route 0.0.0.0 0.0.0.0 20.0.0.1 qui est une route par défaut passant via la passerelle.

Configurer les VLAN sur un switch.

 1) Programmation via GUI.

On peut accéder au switch via une interface graphique du type page web, mais auparavant, il faut configurer le switch de la manière suivante:

Se connecter au switch via un câble V24 en mode hyperterminal (9600, 8N1).
Le VLAN1 est toujours créé par défaut.

Switch>enable
Swtich#configure terminal
Switch(conf)#int vlan1
Switch(conf-if)#ip add 192.168.100.254 255.255.255.0
Switch(conf-if)#no shutdown
Switch(conf-if)#exit
Switch(conf)#exit
Switch#show ip int brief
Switch#copy run start

Reconfigurer la carte réseau du PC avec par exemple ip 192.168.100.1 sans passerelle.
Se connecter avec un câble Ethernet droit sur le dernier port ( port 24).
Faire un test ping sur 192.168.100.254.
Ouvrir Internet Explorer avec 192.168.100.254 pour accéder au menu du switch.
Cliquer sur Smartports dans la barre d’outils supérieure.

2 )Programmation via mode console.

Création d’un VLAN avec affectation d’une interface Ethernet.

  • Un VLAN créé reste inutilisé jusqu’à ce qu’il soit associé à des ports de switch.
  • Tous les ports Ethernet sont situés sur le VLAN1 par défaut.

Switch>enable
Switch#configure terminal                             passage en mode de configuration VLAN.
Switch(config)#vlan numéro_vlan
Switch(config-vlan)#name vlan_name             on donne un  nom au VLAN (optionnel).
Switch(config-vlan)#exit
Switch(config)#interface fastethernet 0/9                            ou int f0/9.
Switch(config-if)#switchport access vlan numéro_vlan     affectation du port Ethernet.
Switch(config-if)#exit
Switch(config)#int vlan numéro_vlan
Switch(config-if)#ip add 192.168.3.254 255.255.255.0     affectation IP au VLAN.
Switch(config-if)#no shutdown
Switch(config)#exit
Switch#show vlan brief              vérification du VLAN.
Switch#copy run start                sauvegarde au reboot.

Suppression d’un VLAN.

On retire d’abord les interfaces Ethernet au VLAN en employant la commande “no”:

Switch(config)#interface fastethernet 0/9                                     ou int f0/9.
Switch(config-if)#no switchport access vlan numéro-vlan         suppression de f0/9.
Switch(config-if)#exit
Switch(config)#no vlan numéro_vlan                                                  suppression du VLAN.
Switch(config)#exit
Switch#show vlan brief
Switch#copy run start
Switch#exit

Création  d’un port Trunk.

Ces commandes sont à passer sur les deux switch associés au Trunk.

Switch>enable
Switch#configure  terminal
Switch(conf)#int f0/23                                        le futur port Trunk.
Switch(conf-if)#switchport mode trunk      création du Trunk.
Switch(conf-if)#exit
Switch(conf)#exit
Switch#show int trunk                                      indique le port de trunk.

Suppression d’un port Trunk.

Switch>enable
Switch#show int trunk                                            indique le port de trunk.
Switch#configure  terminal
Switch(conf)#int f0/23                                              le  port Trunk à supprimer.
Switch(conf-if)#no switchport mode trunk      suppression du Trunk.
Switch(conf-if)#exit
Switch(conf)#exit
Switch#

Définition des Terminaux DCE et DTE.

DCE = Data Communications Equipment. Les DCE marquent le transfert dans un circuit de données. Sont considérés comme des DCE les Hubs, Switch, modems.

DTE = Data Terminal Equipment. Les DTE marquent la fin d’un circuit de données. Sont considérés comme DTE les PC, imprimantes, routeurs.

Entre équipements de la même famille, on utilise des câbles croisés.

Entre équipements de famille différente, on utilise des câbles droits.

Répondre

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion /  Changer )

Photo Google

Vous commentez à l'aide de votre compte Google. Déconnexion /  Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion /  Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion /  Changer )

Connexion à %s